Are you the publisher? Claim or contact us about this channel


Embed this content in your HTML

Search

Report adult content:

click to rate:

Account: (login)

More Channels


Showcase


Channel Catalog


Channel Description:

All Content in vRealize Automation Tools

older | 1 | .... | 400 | 401 | (Page 402) | 403 | 404 | .... | 418 | newer

    0 0

    Since this morning i cannot reach the console of my vcac. When i ping the address from the iaas server i get destination host unreachable.

    From the appliance command prompt the same respons to the IaaS server and the domaincontroller.

     

     

    My root account was locked and i changed the password this morning. After that this strange problem occurred.


    0 0

    Hi everyone!

     

    Are there PowerShell / PowerCLI cmdlets available to request a catalog item from VMware vRealize Automation (vRA)?

     

     

    Thanks in advance,

     

    -Chris

     


    0 0

    Hi, All, i got a very wired issue when try to reqest catalog it by REST API (a,k,a PowerVRA)

     

    I use power VRA to request catalog item, when i feed with JSON, it's failed, but manually request successful.

     

    I have attached a blueprint in file. It's a windows 2012 R2 server with SQL installation, SQL hardening module is rely on MSSQL module to install SQL server, and they share password between.

     

     

    I got error when I request from PowerVRA, it says: One or more of the spawned tasks failed. See task log for more details

     

    The command completed successfully.

    [Error] Please Start SQL Server Services and Try again.

    Error while executing script: Process exited with an error: 1 (Exit value: 1)

     

    It's looks like  the SQL server wasn't finished install while hardening  is kicks in.  Part of request template is here:

     

       "WIN_Base_Settings_1": {

     

       "componentTypeId""com.vmware.csp.component.cafe.composition",

       "componentId"null,

       "classId""Blueprint.Component.Declaration",

       "typeFilter""MicrosoftSQLServer2012R2Servicecopyjuly132017*WIN_Base_Settings_1",

       "data": {

       "_hasChildren"false

      }

      },

       "WIN_MSSQL_2012_1": {

       "componentTypeId""com.vmware.csp.component.cafe.composition",

       "componentId"null,

       "classId""Blueprint.Component.Declaration",

       "typeFilter""MicrosoftSQLServer2012R2Servicecopyjuly132017*WIN_MSSQL_2012_1",

       "data": {

       "_hasChildren"true

      }

      },

       "WIN_MSSQL_2012_Hardening_1": {

       "componentTypeId""com.vmware.csp.component.cafe.composition",

       "componentId"null,

       "classId""Blueprint.Component.Declaration",

       "typeFilter""MicrosoftSQLServer2012R2Servicecopyjuly132017*WIN_MSSQL_2012_Hardening_1",

       "data": {

       "_hasChildren"false

      }

      },

     

    Anybody has running into similar issue? Or what's the proper way to request blueprint when software component has dependency?

     

    Thank you very much....


    0 0

    Hi,

    I'm working on a simple workflow that lets the user select a date.

    The input type is set to date, and when I look at the date in the system log it looks like this "Fri Sep 21 2018 13:17:17 GMT+0200 (CEST)". I only need the date, not the time, and ideally it should be in this format: dd.mm.yyyy.

     

    Iv'e tried using split, but get this message "Cannot find function split in object". I'm guessing I need to convert the date object to a string but I'm struggling to find out how to do that. With a virtual machine object I do it by assigning vm.name to a new variable. I've been unable to find out if I can do the same with date.

     

    Any suggestions on how to accomplish this will be greatly appreciated. I would like to have the user select a date from a calendar if possible, but I'm open to other ways to accomplish this.

     

    Thanks in advance.

     

    GB


    0 0

    Hi,

     

    I want to destroy VM of a VRA showing under Items-->Machine using workflow or action script, Behavior should be similar to invoking Destroy action of VM from VRA. Also I would like know how can I invoke C a t a l o g R e s o u r c e A c t i o n  in action script. Any help with code snippet is much appreciated.

     

    Thanks

     

    Prakash


    0 0

    Can someone tell, when the NSX-T portgroup support is coming? In 7.5?

    I know the compatibility is not there yet. Currently vRA seems to be able to see the port groups, you can for example assign them to a network profile in a reservation. However during deployment, instead of connecting the VM to the port group, a new vSwitch port group is created, attached to the VM but not connected. A manual workaround is to connect them to the correct overlay network. When this is done, the vSwitch pg is automatically removed.

    I am looking for a way to achieve my goal by using a day-2 operation executed by vRO, but vRO does not seem to recognize the NSX-T port groups by default, except if a VM, deployed by vRA, is deployed. So by default no NSX-T pg's are discovered by the vCenter plugin. After a VM has been deployed by vRA, the port group is discovered. If I reconfigure the VM, so that the NIC is connected to the correct overlay network, the vSwitch pg disappears and also the overlay network is no longer visible in the vRO vCenter plugin. My workaround for this issue is to deploy a "dummy" vm using vRA, and assign a NIC for each network profile that includes an NSX-T overlay network. That way I should be able to assign the networks automatically using vRO, since they are now visible in the vCenter plugin.

    edit: a workaround was made available using PowerCLI - Set-NetworkAdapter does not support attaching VMs to | VMware PowerCLI


    0 0
  • 04/18/18--07:11: Plug-In For ITSM for vRA 7.4
  • 1) Do we have vRealize Automation Plug-In For ITSM available for vRA 7.4 ?

     

    2) What version of Service now instance is compatible for 7.4 plugin ?


    0 0

    Hello Expert,

     

    Please help to resolve this problem


    0 0

    Please provide the alternatives / options to use SNOW Kingston ITSM Plug-in for vRealize integration.


    0 0

    Hi All,

     

    Find attached update set xml to uninstall ITSM plugin V3.0

    This file need to be installed prior to committing V4.0 plugin file available on VMware solution exchange and ServiceNow service store .

     

    Please find links for ServiceNow certified plugin V4.0 below-

    VMware Solution Exchange

    https://my.vmware.com/group/vmware/get-download?downloadGroup=VRA_ITSM_PLUGIN_400

     

    ServiceNow ServiceStore-

    https://store.servicenow.com/$appstore.do#!/store/application/843ac90edb120300435fd001cf96190a/4.0.0?referer=sn_appstore…

     

    Also find V3.0 removal script update set attached with this thread.

     

    Regards,

    Manish Patil


    0 0

    Is there any roadmap/timeline for support of existing and comming ServiceNow releases?


    0 0

    I want to build a service, that is triggered after a vSphere VM is destroyed. When VM Destroy is executed, I need a vRO workflow to run. The parameter values are passed using the Extensibility.Lifecycle.Properties.VMPSMasterWorklow32.Disposing property and an event subscription. However, this event subscription is triggered also, when a server is reprovisioned, since both the Disposing and Provisioning events take place. I could not find a Workflow Subscription Condition that references a reprovision action.

    What I want to achieve:

    - User executes VM Destroy action: trigger vRO Workflow

    - User executes VM Reprovision action: vRO Workflow is not triggered

    How can this be done, if at all?


    0 0

    Hello, how can you set the Vrm.DataCenter.Location (or any property for that matter) to a *single* value based off of user input on a Blueprint. 

    What I would like to do is set the Vrm.DataCenter.Location based off of a location property set in a dropdown by the user and a hidden property set on the blueprint.

    My location dropdown has 2 values: North and South, the blueprint will have a statically set property which describes what type of server the blueprint is going to provision. This could be web, middle, db, etc. The combination of the location and the type will be used to set the Vrm.DataCenter.Location. So if the user has set the location to North on the type 'web' blueprint the Vrm.DataCenter.Location will be set to North-web. I would like this to be done transparently in the background (Vrm.DataCenter.Location should be hidden).

    I am able to set the Vrm.DataCenter.Location setting its type to a dropdown and binding the other two properties as inputs to the external source using a vRO action but this forces Vrm.DataCenter.Location to be a dropdown but I don't want this. For one Vrm.DataCenter.Location will always be a single value once a user selects North or South and secondly you can't set a default value on the dropdown when it is populated by an external vRO action which would force the user to have to select the single element in the dropdown!

    I know you can use xml value expressions but I would really, really like to use vRO.


    0 0

    I've been working on an ansible module for vRA to use internally in a reasonably flexible way.  Since the REST API utilizes a payload approach I can setup the flow to work well with vRA so far following the lifecycle of a request.  The challenge I run into is the (this could be the wrong terminology) blueprint ID name does not match the service name and I see no way via the API today to find this relationship.  

    The example code here is a good example:
     

    https://gist.github.com/55a18615fac6c659e3e7524090efe605  (Basically the question is where does vSphere_Machine_1 come from and how can I get it programmatically?)

    Efffectively:

    1. Login and get a Bearer Token
    2. Get the catalog views for an ODATA query based on the name of the request (this is the name you see in the UI in the portal)

    3. Get that request template using the ID from the previous request

    Then everything I"ve seen before to navigate down into the JSON for this request, it has something that is effectively the blueprint ID (which is not the GUID of the request).   This can look something like this:
     

     "reasons": null,
        "data": {
            "CENTOS_7_POSIX": {
                "componentTypeId": "com.vmware.csp.component.cafe.composition",
                "componentId": null,
                "classId": "Blueprint.Component.Declaration",

     --- 

    ...[some header json]

        "data": {

            "CENTOS_7_POSIX": {

                "componentTypeId": "com.vmware.csp.component.cafe.composition",

      ... [lots more json]

    }

    ---

    Then to update and use this request I need to be able to reference the "CENTOS_7_POSIX".  

    ie.  $Form.data.CENTOS_7_POSIX.data.cpu = 12

     

    How do I find the translation table in the API from the name of the service request to what CENTOS_7_POSIX equivalent is?  


    0 0

    It's possible to get the exact creation date of a VM? Using vRA?


    0 0

    Hi!

     

    Does anybody know how to change/edit "Deployment" description after provisioning? End-user can easy change/add VMs description after deployment (using "Reconfigure" task), but I don't see any options to edit Deployment description... I haven't been lucky with vRO/REST API, looks like no methods/functions exists to update already deployed object VCACCAFE:CatalogResource (I'll be happy to be wrong on it). Could not believe that so obvious function is missing in vRA.


    0 0
  • 09/17/18--05:10: Uninstall Plguin (dar)
  • Hi 

    As we make changes in our plugin and deploy in VRA, it is quite challenging to manually clean up(https://docs.vmware.com/en/vRealize-Automation/7.4/com.vmware.vrealize.orchestrator-use-plugins.doc/GUID-F5C8EF0E-C169-43E1-8A6F-D9A191FE129D.html) and install same version again and again. Is there a simple way/script to delete the packages/actions/workflow so that i have some script to invoke the clean up actions

     

    Thanks Prakash


    0 0

    Has anyone got blueprints working with Ovf in 7.4?

     

    Details are a little short on pre-requisites for getting this rolling, and it would be good to know how to get the URL requirement satisfied, for non internet connected deployments.

     

    vraovf.png

    As always, any feedback is appreciated.


    0 0

    Hi All,

     

    Following the KB Article 2099949

    VMware Knowledge Base

     

    I created a new service account for our vRealize automation. While i updated everything in this article i requested a template within the catalog but during the build, it seems that the "Initiated by" is from the old Service account, what else do i need to update inorder to complete move our VRA deployment to the new service account.

     

    Thanks.


    0 0

    I have a simple deployment flow that looks like this.


    I press submit on my Linux blueprint. (..Catalog/blueprint request/submit)

    20sec later the infoblox plugin adds an entry in DNS.

    2min+ later the cloning begins from my vmware-template.
     

    So what makes it wait 2 mins before it starts cloning? Is there a way to shrink this time?
    There must be some value you can tweak? Delays/wait timers between states?
    Which log can i see what happens in the background between infoblox and vm cloning phase?



    I also see wait times later in the deploy workflow which i want to shorten.
    I'm not takning about the vRA Orchestrator workflows here, because i can see them clearly what happens, but all the magic behind the scenes, IaaS maybe? :)



    Thanks for any advise on the matter.


older | 1 | .... | 400 | 401 | (Page 402) | 403 | 404 | .... | 418 | newer