Are you the publisher? Claim or contact us about this channel


Embed this content in your HTML

Search

Report adult content:

click to rate:

Account: (login)

More Channels


Showcase


Channel Catalog


Channel Description:

All Content in vRealize Automation Tools

older | 1 | .... | 352 | 353 | (Page 354) | 355 | 356 | .... | 418 | newer

    0 0

    Hello.

     

    I am trying to deploy an Edge using IP addresses from a given network profile. Instead of manually entering the IP address, I want to find out (programmatically - VRO) the next available IP address for a given Network Profile of VRA. Is there any query/API to do this? The network profile isn't created with an external IPAM server. So, can I query VRA like I do any IPAM server?

     

    Short of iterating through the range and checking its existence in VM/DNS, are there any other method? This is VRA 7.3, BTW. Thanks


    0 0

    We have migrated from vRA 6 to 7.3 and thus lost our XML file for drop down. The new system with its binding and script actions is great, however, I would really like to know if we can do one thing :

     

    When defining the value in the input parameters area of a Dropdown (which I can pass to a script action), can I use a property that I have already defined and attached to the blueprint?

     

    Normally I would bind another property definition to it, but then that property has to be defined in a text area, drop down, etc. I want it to be defined in a property group that is attached to a blueprint.

     

    For example each property group is associated with their own blueprint:

     

    ------

    Property group - AAA Datacenter Environment Prod"

    Hard set "VM.Guest.Datacenter.Network.Pulldown" value to AAA-prod.

     

    Property group - BBB Datacenter Environment Prod"

    Hard set "VM.Guest.Datacenter.Network.Pulldown" value to BBB-prod.

     

    Property group - AAA Datacenter Environment Stage"

    Hard set "VM.Guest.Datacenter.Network.Pulldown" value to AAA-stage.

     

    Property group - BBB Datacenter Environment Stage"

    Hard set "VM.Guest.Datacenter.Network.Pulldown" value to BBB-stage

    ------

     

    Property Definition - "VirtualMachine.Network0.NetworkProfileName"

    Uses script action with input name "datacenter" and value as X where "X" should be the value of "VM.Guest.Datacenter.Network.Pulldown" . The script action will use JS to create a dropdown with the exact network profile names as "Value" and a friendly name as "Name". For example, if the value provided is "AAA-prod", it will show a dropdown of:

     

    Name                    Value

    "DMZ"               -> "AAA Prod DMZ"

    "Protected"       ->  "AAA Prod Protected"

     

    Hope that made sense.

     

    -Alex


    0 0

    I developed a plugin in which I am creating few custom objects and couple of workflows. Once the plugin is installed using vRO control center, service is restarted and all checks are found green under validation screen, I go to vRA and under custom resources try to access the custom object. But I am not able to find my newly installed custom object. I waited for few hours but still no success.

     

    I am using vRA 7.3 with embedded vRO

     

    When I restart vRA appliance then I am able to find my custom object.

     

    Can anyone please let me know how to debug this as this is creating lot of problems for me?


    0 0

    Hi there

     

    My team is using the AWS Default blueprint to provisioning EC2 machines in AWS. VRA v7.3. We want to find out a method of how to limit certain aspects. I'll give you examples:

     

    1. Storage tab - The customer wants us to limit the max size of each storage volume to 100 GB. However, the input field of Storage allows me to type unlimited values. Is there a way to put in limitation using a configuration file or javascript code?

    2. Subnet selection - We have only one subnet created in the VPC. However, in the subnet drop-down we see the one subnet and the default subnet. We don't want to display the default subnet. Is there a way to to limit the drop-down values displayed?

     

    These are just examples of what we want to achieve. Any help will be appreciated.

     

    Thank you.

    Nikhil Gonsalves


    0 0

    Hi team,

     

    we have create "Properties Groups" for BMC EPIagent.

     

    In the documentation here, page 55 is said :

     

    Specifies a software job or policy to be applied to all machines provisioned from the blueprint. Set the value to job_type=job_path, where job_type  is the numeral that represents the BMC BladeLogic job type and job_path is the location of the job in BMC BladeLogic, for example 4=/Utility/putty. NNNN is a number from 1000 to 1999. The first property must start with 1000 and increment in numerical order for each additional property

     

    Ok this is done with the "Properties Group" :

     

    "Vrm.Software.Id1000" = "2=/ASSET/DEV/Windows/EMEA_Baseline/ASSET-Win_Finalization_DC4";

    "Vrm.Software.Id1001" = "4=/ASSET/DEV/Windows/EMEA_Baseline/Office/2016/Office_2016_64_bits";

    Now we want to deploy Vrm.Software.Id1000 in FIRST and after the software Vrm.Software.Id1001, etc.......

     

    Actually Vrm.Software.Id1001 is always deployed in FIRST.

    Of course we have tried to invert the numbers but the Office Package is always the first to be installed

    Do you know how we can force the installation order of BMC Bladelogic Packages with the EPIPowershell agent ?

     

    Thx for your help ...Have a Nice Week


    0 0

    Hi,

     

    This question should maybe be posted in the Orchestrator forum, but I´ll try here first. I´m running a workflow as a post machinebuilding event and in the the script I have defined payload as a input. The first line of the script is "var machine = payload.get("machine");" and it generates the following error "TypeError: Cannot call method "get" of null".

     

    I´m using the exact same line in a pre machinebuilding event and it works fine. My first thought was that "machine" is not available but it does seems to be available since I see this in the logs "'attribute': name=machine type=string" with the correct values.

     

    I am hoping someone can help me with this problem. If more information is needed, please let me know.

     

    Thanks in advance.


    0 0

    Has anyone managed to use the API to allocate Storage Reservation Policies to a Storage Path via the vRA API? I can't seem to figure out where to set this.

     

    The UI version of what I'm trying to do:

     

    Infrastructure -> Edit Compute Resource -> Configuration -> Storage Path -> Drop-down to select Storage Reservation Policy.

     

    The closest I've got is:


    /reservation-service/api/data-service/schema/Infrastructure.Reservation.Virtual.vSphere/default/reservationStorages/values - gets me the datastores

    /reservation-service/api/data-service/schema/Infrastructure.Reservation.Virtual.vSphere/default/computeResource/values - gets me the compute resources I need to edit


    Any help appreciated.




    0 0

    While building a VM I am running into the following error during Customize virtual machine guest OS stage:

    "A specified parameter was not correct: spec.nicSettingMap.adapter.ip.ipAddress"

    My environment is composed of vRA 7.3, vRO 7.3 and vCenter 6.5. Does anyone know a solution to this issue?

    Thanks.


    0 0
  • 03/16/18--09:29: Parse Curl output
  • Hello Everyone,

    I am using below Curl command (output of VRA programing Guide) to get list of all the request

    curl --insecure -H "Accept: application/json" -H "Content-Type: application/json" -H "Authorization: Bearer $token" https://$vRa/catalog-service/api/consumer/requests/

    I want to parse the output so I can get it in a table format and the required fields only. Please let me know how I can parse the output.

    Thanks,

    Milind MK.


    0 0

    VMware vRealize Automation 7.3.1 is now available


    Whats New?

    • This release contains resolutions for 73+ issues reported on .vRealize Automation 7.2 and 7.3, as well as multiple security updates
      For more information, see Resolved Issues.

     

    Documentation and Links:


    0 0

    I have a requirement to show the virtual machine files to the user in form of tree structure.

    I could see we have a way to use External values in form of actions to populate the tree but I have question on the below,

     

    1. What Entity Type do we map if the input field is tree type? Is there a mapping list that I can use?

    2. The external value had no option to use the other input field value selected, in this case I need to have the VM to show the files to user.


    0 0

    It has been a while since I looked at this, but has anyone discovered a way to do targeted data collection?  (e.g.  vm updated cpu/mem/disk in vsphere reflected in VRA without Reconfigure D2 operation)

     

    daphnissov

     

     

    Thanks,

    ~Sean


    0 0

    Hello and thanks for taking the time to help me out.

     

    Basically, I’m trying to make it so when a blueprint is request, it creates a folder in vSphere that creates a tree that goes <name>/<project>/<date-time> based mostly on user inputs, and then dumps the provisioned vm's in there.

     

    The blueprint prompts for the username and the project they are working on, and then creates that folder tree in vSphere but also creates another sub folder of <date-time>.

     

    I've created a Property Group, that says to put the VM in a folder tree in vSphere with the structure of  <name>/<project>/<date-time>.

     

    I’ve then been able to create Property Definitions for <name> and <project>, and when a user enters them during the blueprint request, it does go to vSphere and it does create that folder structure and dumps the VM's in there. This is as expected.

     

    The problem is getting a Property Definition for <date/time>.

     

    When setting up a Property Definition, It does a have a Date/Time picker in there but I don't want the user to be able to pick the date/time, i just want it to be the current date/time that the blueprint was provisioned.

     

    Is there any way to easily extract the current date time and then apply it to a 'Date/Time' Property Definition? or some other way to apply the current date time to the folder structure?

     

    Hope that makes sense.

    Thanks for your time.


    0 0

    Hi,

     

    I am using VRA version 7.3 and sometimes the workflows presentation screen does not load when I click on execute workflow or when we try to run the workflow again.

    Does anyone know the reason and a fix for it. I have tried refreshing the workflows and also modified the file again and saved it. Nothing seems to work.


    0 0

    Good morning


    using vRA 6.2.1 for a number of months now but when trying to build a machine i am getting


    A server error was encountered Error requesting machine. Machine xxx: Allocate reservation operation failed for business group yyy. No reservation available to allocate the requested resources..


    However I have a reservation which has enough RAM and Storage allocated but it still refuses to build not matter what i try


    What can I check / try next?


    0 0

    Hi,

     

    We are trying to set defaults for the AWS instance Blueprint deployment. Is there any way to hide items such as the provision into , location and setting defaults.  I understand we can create a XAAS blueprint and do a workflow that does a catalog request, but that seems like such a roundabout way to do something to help simplify the provisioning workflow and make it useable for business users.

     

    29-11-2017 9-59-14 PM.jpgHi


    0 0

    Hi,

     

    I am trying to create a workflow subscription and publish it.

     

    This is what I am seeing,

     

    1. Register A workflow subscription is unable to create the subscription as it fails in setting the criteria using the JSON string,

         Error:   (com.vmware.library.vcaccafe.workflow.subscription/createWorkflowSubscription) Error in (Dynamic Script Module name : createWorkflowSubscription#14) Unable to convert target json string to clause object

     

    I had obtained the criteria using another subscription and then called JSON.stringify on the response and passed it to the function.

     

    2. I used the same JSON string and tried creating a workflow subscription, surprisingly that works.

     

    3. I want to publish the subscription and looks like if we just create the workflow subscription, it does not publish it even when the status is PUBLISHED. And just creating the subscription does not register it with vCACHost so I had to go with the route

    A. register workflow subscription

    B. publish workflow subscription

     

    Can someone please suggest what is wrong in this or if the method has some bug in 7.3 version.

     

    Thanks for your time and help!


    0 0

    I have to try to download the vra7 product from my VMWare account but I'm not a superuser that's why I have faced the problem.

     

     

    Could anyone please share the link?

     

     

    Basically showed the bellow message...

     

     

    You either are not entitled or do not have permissions to download this product.

    Check with your My VMware Super User, Procurement Contact or Administrator.

    If you recently purchased this product through VMware Store or through a third-party, try downloading later.

     

     

    Overall I need the vra 7 ovf file if anyone help


    0 0

    I have to try to download the vra7 product from my VMWare account but I'm not a superuser that's why I have faced the problem.

    Could anyone please share the link?

    Basically showed the bellow message...

     

     

    You either are not entitled or do not have permissions to download this product.

    Check with your My VMware Super User, Procurement Contact or Administrator.

     

    If you recently purchased this product through VMware Store or through a third-party, try downloading later.

     

     

    Overall I need this ovf.......


    0 0
  • 02/07/18--17:20: No sensors defined - Error
  • Anyone seeing this error inside the vRealize Module > Logs

     

    REST call error found inside VRASNRequestUtil.preImportRequest: No sensors defined

    REST call error found inside VRASNAuthGenerator.generateAuthCode: No sensors defined

    REST call error found inside VRASNRequestUtil.preImportRequest: No sensors defined

    REST call error found inside VRASNImportCMDB.reconcileCMDB for pagination: No sensors defined

    REST call error found inside VRASNImportCMDB.preImportCMDB: No sensors defined

     

    We're seeing it across multiple script includes.functions

     

    ServiceNow ticket opened; This error can be fixed by adding a line of code "request.setEccParameter('skip_senor',true)", but that would man changing a lot of plugin code. We have raised a HI ticket also for this but they are also giving the same solution and directing to check with vRealize support for the fix.


older | 1 | .... | 352 | 353 | (Page 354) | 355 | 356 | .... | 418 | newer