Are you the publisher? Claim or contact us about this channel


Embed this content in your HTML

Search

Report adult content:

click to rate:

Account: (login)

More Channels


Showcase


Channel Catalog


Channel Description:

All Content in vRealize Automation Tools

older | 1 | .... | 318 | 319 | (Page 320) | 321 | 322 | .... | 418 | newer

    0 0

    Hi,

     

         I'm struck on my lab. I've need to uninstall software component only but when i click Actions it's found Empty.

    My user is a Super user.

    Role:

    TA, IaaS, Fabric, XaaS,
    Infrastructure

     

     

    9-16-2016 1-39-31 PM.jpg


    0 0

    Hello and happy November!

     

    I'm relatively new to the vRA arena and have been struggling with an issue in one of our workflows for a while. We have a XaaS component that relies on the output of one of the previous XaaS components to use as an input. Before the workflow kicks off, Pool1 doesn't exist, so I can't add a member to it in the next component in the workflow. Here it is in a nutshell:

     

    *A pool is created without any members, the pool name is Pool1

    *A pool member, PoolMem1 is created and needs to be added to Pool1

     

    The problem comes when I'm trying to specify that PoolMem1 needs to go into Pool1, because Pool1 doesn't actually exist yet; it's created during the workflow. I need to map the output of the first component (in this case Pool1), to the second component in the workflow, so that PoolMem1 has a pool to go into. This seems like such a common scenario that I feel like I'm totally missing something that should be very obvious to me.

     

    Anyone have experience with this? I really appreciate any insight!

     

    Thanks!


    0 0

    Our app team has requested a workflow that will add a CNAME into DNS for dev boxes. In and of itself this is pretty easy to do. I also decided that it should have a lease so the CNAMES can be cleaned up every 30 days unless extended.  Has anyone came across something like this before?


    0 0
  • 11/01/17--08:13: Software Components
  • Hello,

    Currently in our provisioning process we use a software component to format the disk and file system on our linux and windows machines.  If we want to extend a file system that is part of a software component how do I go about doing that?  Just updating the software component and the script will automatically run or is there something else I have to do?


    0 0

    I have a requirement to deploy AWS CloudFormation template from vRA self-service portal. The requirement is to use custom parameters which we need to ask end-user in the form such as prod vs non-prod, region, load balancer (yes\no), etc... 

    I explored vRO plugin for AWS but didn't find any workflow or out-of-box way to deploy CloudFormation template to build the stack in AWS cloud.

    Please suggest the best way to develop this automation in VRA\VRO.


    0 0

    Want to get a $100 Amazon gift card right on time for your Black Friday? For our vRealize Automation (vRA) customers, we are now giving you the best chance to win it! Here goes the simple three-step instruction:

    • Visit VMware Marketplace and find all available vRealize Automation blueprints here
    • Download and import a blueprint into your vRA environment
    • Leave a review (click “review” tab) and share your feedback with our customer community

     

    Then you will be entered the raffle drawing automatically. More reviews, better chances!

    Your Feedback is Important!

    While we start working on the next batch of blueprints, the team needs your help to continuously deliver what really matters to our valued customers, like you. Please leave your comment and feedback on our Marketplace when you try these new blueprints. Don’t forget that you may be the lucky one to receive the exciting reward. Looking forward to your participation!

    Read the blog here to learn more details.

     

    https://blogs.vmware.com/management/2017/11/18635.html


    0 0

    Hello everyone,

     

    This is my first post so excuse me if i'm missing some information or if i'm not posting in the right place.

     

    Environment:

    • Single VRA 7.3 deployed as appliance with VRO embedded
    • 2 endpoints = 2 linked vCenter on two different geographic place (US/EMEA)

     

    Status:

    • Blueprint for all OS created and working fine (workflow point of view)
    • Blueprints not associated to any reservations since it would be overriden by location and size at request
    • Changed the datacenter file on the IAAS server and associated each resource group to a location
      • Ability to select a location on the request is working fine

     

    Issue:

    I created 4 values for the component profile "size" (small, medium, large, xlarge). I assigned this profile to each blueprint and assigned the small value as default.

    No matter which profile i select during the request, it will always resize the memory and CPU but not the disk.

    From reading here and there, i kind of understand that to resize at the OS level, it needs to be done through a script (is it right?) but it's not even changing the size at the VM level.

     

    Does someone have any input ? anywhere to start looking ?

     

    Thank you in advance,

    Benjamin.


    0 0

    Hello all,

     

     

    The environment contains:

    2 vRA 6.2.3 (Load Balancer) / 2 vRA IaaS Web (Load Balancer) / 2 vRA IaaS Manager (Load Balancer Active-Passive)  / 2 vRA IaaS DEM (Load Balancer) / 2 vRA IaaS Agent (Load Balancer) .

     

    Summary:

    At the last week, I encountered a problem with the "VMware vCloud Automation Center Service" (on vRA IaaS Manager),

    The service was up and running on both managers - normal mode is when the service auto and running on first, and manual and stop on the second.

    Has anyone ever come across such a situation?


    0 0

    I am doing a demo of this plugin and our instance does not have ADFS and after reading the documents I did not see where I could configure the plugin without ADFS.


    0 0

    I can login and authenticate with the exact same credentials with any issues to https://vchs.vmware.com/ .  My user has admin access.

    But when I setup the endpoint in vRA i get the following error and unable to deploy to vCloud Air.

    Anyone else run into this problem?

     

    VCloudGetInstances: Compute 143-898: Failed to get vCloud login session. Exception: System.AggregateException: One or more errors occurred. ---> DynamicOps.Common.Client.HtmlResponseException: Unauthorized (401)

    Request:

    POST https://vchs.vmware.com/api/vchs/compute/4314-932f-e62029d4886e/vdc/b0592ad9-de1e-4d23-a418-b26fbef8cf58/vcloudsession

    Response:

    <Error minorErrorCode="" majorErrorCode="401" message="Unauthorized" xmlns="http://www.vmware.com/vchs/v5.6" xmlns:tns="http://www.vmware.com/vchs/v5.6" xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"/>

    at DynamicOps.Common.Client.RestClient.HandleErrorResponse[TResponse](ObjectContent request, HttpResponseMessage response, CancellationToken cancellationToken)

    at DynamicOps.VCloudModel.Interface.AuthenticatedRestClient.<>n__FabricatedMethod8[TResponse](ObjectContent , HttpResponseMessage , CancellationToken )

    at DynamicOps.VCloudModel.Interface.AuthenticatedRestClient.<HandleErrorResponse>d__4`1.MoveNext()

    --- End of stack trace from previous location where exception was thrown ---

    at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)

    at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)

    at DynamicOps.Common.Client.RestClient.<HandleErrorResponse>d__a7`1.MoveNext()

    --- End of stack trace from previous location where exception was thrown ---

    at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)

    at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)

    at DynamicOps.Common.Client.RestClient.<PostResourceInternal>d__c1.MoveNext()

    --- End of stack trace from previous location where exception was thrown ---

    at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)

    at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)

    at DynamicOps.Common.Client.RestClient.<PostResource>d__87`1.MoveNext()

    --- End of inner exception stack trace ---

    at System.Threading.Tasks.Task`1.GetResultCore(Boolean waitCompletionNotification)


    0 0
  • 11/02/17--10:03: Revert snapshot Event?
  • I'm trying to find an event to subscribe to that would fire when a VM is reverted to its snapshot, so that I can then power-on the VM, but I'm not having much luck. Can anyone point me in a direction?

     

    Thanks!


    0 0

    we are preparing to deploy vRA 7.3 per the VVD 4.1. The one item that i have failed to find in the VVD or via some Google-Fu is the suggested placement of servers that serve as extensions for vRO, more specifically Powershell script host.  Most of the vRA stack sits in the management cluster for a region except for items like vROPS Data Collectors and IaaS Agent servers that both sit in the Compute cluster of a Region.

     

    My problem is that I can make arguments for each placement that both seem valid. I don't think it matters (much) but I am just trying to make sure i stick to the VVD when able.

     

    Thanks,


    0 0

    Hi all,

     

    I'm running the following command to find the machine details (including custom property definitions) through vRealize Automation REST API:

     

    https://{{vraInstance}}/iaas-proxy-provider/api/services/{{providerRefId}}/resources/types/{{Infrastructure.Cloud}}/{{providerBindingID}}?includeAllProperties=true

     

    After looking at the 7.3 API Guide here:

     

    vRealize Automation IaaS Proxy Provider Service API - VMware API Explorer - VMware {code}

     

    It states that this particular API is being depreciated. I've been digging through the API a bit and haven't been able to find something similar that is not being depreciated. Does anyone know where this functionality is migrating towards? My best guess was something like:

     

    https://{{vraInstance}}/catalog-service/api/consumer/resources/{{resourceId}}

     

    Which doesn't list the custom properties I'm after.


    0 0

    Does anyone know if there are any other packages for dynamic types for AWS objects? Or are they updating the plugin with more than EC2?


    0 0

    I've changed the time zone to US - Pacifc as part of the deployment of VRA 7 and double checked that it's correct on the VRA appliance console.   However, emails are getting sent out that use Coordinated Universal Time and I can't find where that needs to be changed. 


    0 0
  • 11/03/17--03:06: [vRA] - Proxy agent BMC
  • Yep,

     

    we search an information about "BMC Proxy Agent" .....

     

    It's works with Windows client machine ... BUT it's also available with Linux Client machine ?

     

    We don't find this information.

     

    thx for your help.


    0 0

    Hello everyone,

    I've already deploy and well configured (i think) the vRealize Appliance. I connected it to my vCenter. All the options of my vRealize Automation are available except this one Health in Administration tab:

    I set all the network configurations (proxy, etc.) for the vRealize Appliance. I don't now if i had to set others config in the appliance itself or not to access this Health option.


    0 0

    Hello,

     

    We have a newly deployed distributed vRA 7.3 environment spanning across two DCs, main DC contains the core vRA components with two DEMS and two Proxy Agents (vSphere) and the second DC hosts two DEMs and two Proxy Agents (vSphere). There is a resource vCenter in each DCs.

     

    Perhaps there are missing firewall flows but I believe we have them all them in place as we were able to successfully deploy the DEMs and Proxy agents to our remote Datacenter. We have F5 load balancers for the vRA appliances, the Web servers and Manager servers.   

     

    I have noticed that on the main vRA node under the Host Settings tab we see partial and missing information and on the Cluster tab we do not see any info at all.

     

    Anyone else experienced this?

     

    Thanks,

    Luc

     


    0 0

    Is this possible to reboot between software installations when using the vRealize Guest Agent instead of software components?

     

     

    1. VirtualMachine.Software0.ScriptPath     softwareinstall0
    2. VirtualMachine.Software1.ScriptPath   <---- Reboot
    3. VirtualMachine.Software3.ScriptPath     softwareinstall3

     

    I'm assuming the agent will continue after the reboot, is this correct?

     

    Thanks in advance

     

    Andy Sanderson


    0 0

    I'm attempting to migrate resources to new business group, which works fine for resources that don't have any software components. The resources with software components will not migrate. If I use the 'Change reservation of an Iaas Virtual Machine' workflow in vRO, I can get the VM resource to move, but the software components stays on the old business group which then leaves the deployment on the old business group.

     

    Has anyone else ran into this?


older | 1 | .... | 318 | 319 | (Page 320) | 321 | 322 | .... | 418 | newer